Fulcrum Outage
Incident Report for Fulcrum
Resolved
This incident has been resolved.
Posted Jul 21, 2021 - 13:38 EDT
Investigating
We are currently investigating this issue.
Posted Jul 21, 2021 - 13:26 EDT
This incident affected: Fulcrum (United States) (Mobile Sync, Web, Query Service) and Fulcrum (Australia) (Mobile Sync, Web, Query Service).