Slow response times

Incident Report for Fulcrum

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 23:23 EDT

Monitoring

Service performance has improved and the application is now responding more consistently. Our team is currently running tests to confirm full stability and ensure all services are operating as expected. We will continue to closely monitor performance and share another update soon. Thank you for your patience.
Posted Oct 20, 2025 - 12:22 EDT

Update

We are actively shifting services to a alternate backup environment to minimize impact from an issue affecting one of our infrastructure providers.
Posted Oct 20, 2025 - 11:17 EDT

Identified

We have identified an issue with one of our third-party providers and are proactively moving to a backup environment to minimize impact. Our team is actively monitoring the situation and working to restore access as quickly as possible
Posted Oct 20, 2025 - 11:13 EDT
This incident affected: Fulcrum (United States) (Mobile Sync, Web, Query Service, 3rd Party Services).