Importer and exporter downtime

Incident Report for Fulcrum

Resolved

Our Engineering team has resolved the issue that was causing the Importer and Exporter to fail.
Posted Jul 10, 2026 - 03:25 EDT

Identified

We are currently investigating an issue affecting the Importer and Exporter. Our team has identified the root cause and is actively working on a fix
Posted Jul 10, 2026 - 02:30 EDT
This incident affected: Fulcrum (United States) (Web) and Fulcrum (Australia) (Web).